Start a new topic

Weather update - new problem

Another problem happened after the new update: Switch the speed to km/h and the results here: .4.4 km/h (see the double dots)

1 person has this problem

After the firmware update of a few days ago, my weather info does not update anymore. Temperature and wind speed stay the same. Before the update, is was working fine.

Hendre, did you go in to the settings and update your location? I’ve noticed since the update, the weather updates even slower. Mine has said it’s partly/mostly cloudy and 75°. It’s been raining for a couple hours now. shows rain, but my LaMetric is updating even less it seems. It’s very frustrating. I don’t understand why it can’t check for a new update every 30 minutes.

Yes, I did. Even tried changing the location to a nearby town. Made no difference.

BUT, since posting the above comment, I have changed the location to "Auto" and it updated the data to what it was at the time. It is now 3 hours later and the information hasn't changed in the 3 hours. 

Opening the app, changing the location to something else and re-enabling the auto location feature, seems to force an update.

As you say, very annoying. Weather data was one of the main reasons why I bought the LaMetrics (3 of them)

Same problem here: I can choose the location but it's not updating automatically. Before they changed the wether provider it worked without any problems.

Hi everyone,

We are working on the issue to provide the updates shortly. We'll keep in touch with you.
Apologies for the inconvenience caused.

We have released the new 2.0.13 firmware version, it contains weather app bug fixes.
Please update your software and check if the issue persists.

My problem has been fixed. Thanks you.


It still does not work for my location Colmar, France

Weather App is displaying wrong data with always the same values.

If the issue with the Weather app still persists please drop an email to


Stopped working for me too. It was working okay, today it stopped. Support email sent.

Should work now, please check!

Hello, I confirm. Seems to work now. Great 

Works also for me now. Thanks a lot!

Login or Signup to post a comment