Start a new topic

Your smartphone has disconnected from Lametric Time on Iphone

Hello, i recieved my Lametric Time yesterday and i tried to connect it to my iphone 12. During the connection, I always have the same error which tells me that "Your smartphone has disconnected form Lametric Time". I also tried on Iphone X but nothing works. However, on a samsung S8, the configuration works and the Lametric is 100% operational. Do you know why it does not work on my iphone ?

Thanks for your answer 

5 people have this problem

Same thing. Dead device with no wifi, version 2.7.0 downloaded from the store today and it's 2 months old. 

An absolutely unacceptable out of the box experience. 


Many thanks for your patience.

There was an issue with the connection to the device and recently we have released the new firmware update (v.2.2.1) with bug fixes.
Please follow the next steps and update your firmware:

1) Turn your device off.
2) Connect device to PC using USB cable. 
3) Start device in Recovery mode (press and hold Volume Up button and short press the On/Off button at the same time). 
4) Mount mass storage (navigate in Recovery mode to ‘MOUNT’ using Left or Right navigation buttons and confirm with Action button).
5) PC should detect new mass storage device and LaMetric will be temporarily locked.  

6) Drop the latest software file from to the root folder of the disk drive that appeared on your PC.
7) Safely disconnect LaMetric from PC and reboot it (navigate to ‘REBOOT’ using Left or Right buttons and confirm with Action button).

8) The software will be installed automatically. The device will reboot few times.

After that try to configure your LaMetric Time. Here are links if you are on Android or iOS.

If you have any questions, please drop an email on


Hello, i slill have same issue "You iPhone is disconnected from LaMetric Time", i have last firmware 2.2.2 in cant connect, i tried lie 100 times. Help me!

Can i install 2.2.1 firmware to try resolwe the issue? obvoiusly it doesnt work now for me. Im using an iPhone 13, the issue started when i installed last firmware.

Honestly I couldn’t get it to work for the life of me. I had to set it up using and android device then it worked on my iPhone once it was set up

You set it on android and then restore it and its started to work on iphone?

Same problem. Don't have access to an Android phone. Any solution to this?
Same problem here. I've reconfigured the La Metric multiple times, rebooted router, nothing fixes the issue... For the first few days the app works then suddenly the app cannot find La Metric on the network (the device clearly us still connected to the internet/network, the apps get live updates), but the iPhone app can't find the device on the network.

This is honestly the most frustrating device I have ever tried to set up, I saw a review that said this and thought they were exaggerating but it's so true, over 4 hours trying to get it to set up and still nowhere. Every single time the phone says this, but is it clearly connecting to my network


and is clearly making requests


UPnP is on, mDNS reflector is on, IGMP is not blocked but no matter what I do I always get this message on my phone and so it doesn't show up in the app but La Metric switches to showing the time, radio etc

and suddenly, 300th time lucky


Is this a new issue after the recent update? My app did not even recognise the device on the devices list and when I reset it, I can not connect back to it at all. Super frustrating. 

I've followed all of the tips in this thread, but still no luck.

The clock works on its own displaying the date and time, but I have anbeolutely no control over it. 


1 person likes this


We are sorry about your experience.

Could you please try to grab logs via USB for our investigation? Please grab them just after the issue has occurred.

  1. Press the power button fast three times in a row (within 1 second) when the device is turned on.
  2. Connect device to your computer via USB cable.
  3. Reboot device in mass storage mode (see user guide for reference). New disk drive should appear on your computer.
  4. Open newly created disk drive and send to files found in "Logs" folder.
  5. Safely eject disk and reboot the device.

Find the instruction on how to mount the device as mass storage here (Section 5.5, page 62, steps 1-4). 

Thanks in advance.

I have the same problem on my iPhone but I could just login and use the device with the iOS app my MacMini M1.

Doenst work on iphone it's so dissapointing... 

Login or Signup to post a comment