Start a new topic

Cannot connect to LaMetric WiFi at init


I received my LaMetric Time yesterday and couldn't connect to its direct WiFi (LM0920). It tries and always ends up saying that the connection failed.

Tried with several devices and all failed. Updated it with latest firmware through USB, rebooted it, still doesn't work.

Thanks for your help.

PS: tried sending a support ticket but for some reason it didn't work!


We received your support ticket.

Thank you for the provided information, the concerned team is working on the issue.

I have the exact same problem. Please advice!

Best regrds,



Please send us your device logs via the support ticket (use the Support button in your LaMetric app). This would be very helpful.

The problem is that I cannot connect the device to the LaMetric app. Therefore I cannot provide device logs ...



Please try to grab logs from the device via USB. Follow these steps:

  • Press the power button fast three times in a row (within 1 second) when the device is turned on.
  • Connect device to your computer via USB cable.
  • Reboot device in mass storage mode (see user guide for reference). New disk drive should appear on your computer.
  • Open newly created disk drive and send us files found in "Logs" folder.
  • Safely eject disk and reboot the device.

Here is instruction how to mount device as mass storage: (Section 5.7, page 40, steps 1-4).

 here you go!



Thank you. We'll get back to you soon.

same issue...

Same here.

For info, I had to return my device...

Usually issues may be related to the network settings.

Please make sure your network is supported.

For further assistance please contact

Did anyone ever get a fix as my LaMetric worked fine until three months ago & now I can’t even seem to get on the units own wifi either & I’ve done everything above.

Hi @Kriss!

Please drop an email with detailed information on It would be helpful to get any screenshots/photos/video demonstrating the issue.

Thanks in advance.

Best regards,

LaMetric Team

I already have but have to wait until my next rotation ends before I can reply etc.
Login or Signup to post a comment